鸿运国际官网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!

牛股排序 源码 通达信 贴图

[下载地址]
鸿运国际官网经过测试可运行,该软件通过多款专业杀毒软件扫描
  1. 360通过
  2. 金山通过
  3. 瑞星通过
  4. 江民通过
  5. 卡巴通过
  6. 诺顿通过
  1. 运行平台:Win7/Vista/WinXP/Win2003/
  2. 公式语言:简体中文
  3. 更新时间:2018-06-11 08:28:00
  4. 公式评级:
  5. 公式类型:鸿运国际官网
  6. 授权方式:共享版
  7. 公式大小:18.0 KB
  8. 解压密码:goodgupiao
  9. 下载统计:
  10. 相关Tags:
已有次下载
推 荐0
不推荐0

牛股排序 源码 通达信 贴图介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:牛股排序 源码 通达信 贴图
牛股排序 源码 通达信 贴图

周月RSI引用
{周月RSI引用}
N1:=6; N2:=12; N3:=24;
LC:REF(CLOSE,1);
YN11:SMA(MAX(CLOSE-LC,0),N1,1);
YN12:SMA(ABS(CLOSE-LC),N1,1);
YN21:SMA(MAX(CLOSE-LC,0),N2,1);
YN22:SMA(ABS(CLOSE-LC),N2,1);
YN31:SMA(MAX(CLOSE-LC,0),N3,1);
YN32:SMA(ABS(CLOSE-LC),N3,1);


大成2源码:
{大成2}
M5:=MA(CLOSE,5);
M10:=MA(CLOSE,10);
M20:=MA(CLOSE,20);
M60:=MA(CLOSE,60);
X1:=H=C;
XZ2:=C>O;
X3:=O>MA(C,60);
X4:=MA(C,60)>MA(C,5);
X5:=MA(C,5)>L;
X6:=L>MA(C,10);
X7:=MA(C,10)>MA(C,20);
文:=X1 AND XZ2 AND X3 AND X4 AND X5 AND X6 AND X7;{44.32}
贵2:=H=C;
贵3:=C>MA(C,20);
贵4:=MA(C,20)>MA(C,5);
贵5:=MA(C,5)>O;
贵66:=O>=L;
贵7:=L>MA(C,10);
贵:=贵2 AND 贵3 AND 贵4 AND 贵5 AND 贵66 AND 贵7;{45.75}
贵州1:=MA(C,20)> MA(C,10) ;
贵州2:= MA(C,10)> H ;
贵州3:= H= C;
贵州4:= C> MA(C,5) ;
贵州5:= MA(C,5) > O ;
贵州6:= O> L ;
贵州7:= L> MA(C,60) ;
贵州:=贵州1 AND 贵州2 AND 贵州3 AND 贵州4 AND 贵州5 AND 贵州6 AND 贵州7;{41.53}
泰1:=H=C;
泰2:=C>O;
泰3:=O>L;
泰4:=L>MA(C,60) ;
泰5:=MA(C,60)>MA(C,5) ;
泰6:=MA(C,5)>MA(C,10) ;
泰7:=MA(C,10)>MA(C,20) ;
泰:=泰1 AND 泰2 AND 泰3 AND 泰4 AND 泰5 AND 泰6 AND 泰7;{36.07};
天1:=H=C ;
天2:=C>O ;
天3:=O=L ;
天4:=L>MA(C,5) ;
天5:=MA(C,5)>MA(C,10) ;
天6:=MA(C,10)>MA(C,20) ;
天7:=MA(C,20)>MA(C,60) ;
天Z:=天1 AND 天2 AND 天3 AND 天4 AND 天5 AND 天6 AND 天7;{42.33};
华森1:=H=C;
华森2:=C>MA(C,20) ;
华森3:=MA(C,20)> MA(C,10) ;
华森4:=MA(C,10)> MA(C,5) ;
华森5:=MA(C,5)>O ;
华森6:=O>L ;
华森:=华森1 AND 华森2 AND 华森3 AND 华森4 AND 华森5 AND 华森6 ;{41.73}
蓝1:=O = H ;
蓝2:=H = C ;
蓝3:=C > L ;
蓝4:=L > MA(C,5) ;
蓝5:=MA(C,5) > MA(C,60) ;
蓝6:=MA(C,60) > MA(C,10) ;
蓝77:=MA(C,10) > MA(C,20) ;
蓝:=蓝1 AND 蓝2 AND 蓝3 AND 蓝4 AND 蓝5 AND 蓝6 AND 蓝77; {33.97}
中1:=H > C ;
中2:=C > MA(C,60) ;
中3:=MA(C,60) > O ;
中4:=O > MA(C,5) ;
中5:=MA(C,5) > L ;
中6:=L > MA(C,10) ;
中7:=MA(C,10) > MA(C,20) ;
中C:=中1 AND 中2 AND 中3 AND 中4 AND 中5 AND 中6 AND 中7;{41.19};
万1:=H=C;
万2:=C>MA(C,20);
万3:=MA(C,20)>MA(C,5);
万44:=MA(C,5)>MA(C,10);
万5:=MA(C,10)>O;
万6:=O=L ;
万:=万1 AND 万2 AND 万3 AND 万44 AND 万5 AND 万6 ;
宏1:=H=C;
宏2:=C>O;
宏3:=O=L;
宏4:=L>MA(C,60);
宏5:=MA(C,60)>MA(C,5);
宏6:=MA(C,5)>MA(C,10);
宏7:=MA(C,10)>MA(C,20);
宏:=宏1 AND 宏2 AND 宏3 AND 宏4 AND 宏5 AND 宏6 AND 宏7 ;
盘1:=H=C ;
盘2:=C>MA(C,60) ;
盘3:=MA(C,60)>MA(C,10);
盘4:=MA(C,10)>MA(C,5);
盘5:=MA(C,5)>MA(C,20);
盘6:=MA(C,20)>O;
盘7:=O>L;
盘:=盘1 AND 盘2 AND 盘3 AND 盘4 AND 盘5 AND 盘6 AND 盘7;
诚1:=H=C;
诚2:=C>O;
诚3:=O=L;
诚4:=L>MA(C,10) ;
诚5:=MA(C,10)>MA(C,60) ;
诚6:=MA(C,60)>MA(C,5) ;
诚7:=MA(C,5)>MA(C,20) ;
诚:=诚1 AND 诚2 AND 诚3 AND 诚4 AND 诚5 AND 诚6 AND 诚7;
九1:=H=C;
九2:=C>MA(C,60) ;
九3:=MA(C,60)>MA(C,10);
九4:=MA(C,10)>MA(C,5);
九5:=MA(C,5)>MA(C,20);
九6:=MA(C,20)>O ;
九7:=O>L;
九:=九1 AND 九2 AND 九3 AND 九4 AND 九5 AND 九6 AND 九7;
创1:=MA(C,60)>H ;
创2:=H=C;
创3:=C>MA(C,5);
创4:=MA(C,5)>O;
创55:=O>MA(C,20);
创6:=MA(C,20)>L;
创7:=L>MA(C,10) ;
创:=创1 AND 创2 AND 创3 AND 创4 AND 创55 AND 创6 AND 创7;
华锋1:=H=C;
华锋2:=C>MA(C,10);
华锋3:=MA(C,10)>MA(C,5);
华锋4:=MA(C,5)>MA(C,20);
华锋5:=MA(C,20)>MA(C,60);
华锋6:=MA(C,60)>O;
华锋7:=O>L;
华锋:=华锋1 AND 华锋2 AND 华锋3 AND 华锋4 AND 华锋5 AND 华锋6 AND 华锋7;
永1:=H=C;
永2:=C>MA(C,10);
永3:=MA(C,10)>MA(C,20);
永4:=MA(C,20)>MA(C,5);
永5:=MA(C,5)>MA(C,60);
永6:=MA(C,60)>O;
永7:=O>L;
永:永1 AND 永2 AND 永3 AND 永4 AND 永5 AND 永6 AND 永7;
均总:文+贵+贵州+泰+天Z+华森+蓝+中C+万+宏+盘+诚+九+创+华锋+永;
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1);
红水平线:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1);
黄水平线:=DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1);
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1);
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
洋红水平线:=DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1);
青水平线:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1);
{*1}C穿黄水平线:=CROSS(C,黄水平线);
今强:(-(HHV(EMA(C,5),14)-C)/C*5000);
X2:=BARSSINCE(15);
EX2:=SUM(X2,3);
XX2:=X2*X2;
EXX2:=SUM(XX2,3);
Y2:=MA(今强,13);
YY2:=Y2*Y2;
XY2:=X2*Y2;
EY2:=SUM(Y2,3);
EYY2:=SUM(YY2,3);
EXY2:=SUM(XY2,3);
强度CO:=((3*EXY2-EX2*EY2)/SQRT((3*EXX2-EX2*EX2)*(3*EYY2-EY2*EY2)));
MA强度:=MA(强度CO,4);
AR1:=AMOUNT/VOL/100;
AR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
AR3:=SUM(AMOUNT,34)/AR1/100;
AR4:=DMA(AR2,VOL/AR3);
AR5:=100*(C-AR4)/AR4;
次强上轨:=(MA(AR5,20)+STDP(AR5,20));
次强下轨:=(MA(AR5,20)-STDP(AR5,20));
差强弱线:=(次强上轨+次强下轨)/2;
强势上轨:=(MA(AR5,20)+1.7*STDP(AR5,20));
强势下轨:=(MA(AR5,20)-1.7*STDP(AR5,20));
差标准:=AR5;
{*2}差标上:=(CROSS(差标准,强势上轨) AND CROSS(差标准,次强上轨));
{相对MACD首创,传统指标深度挖掘:相对MACD,理解并用好就会发财。}
DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
MACD:=2*(DIF12-DEA12);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);
买卖力道:=2*(KDIF12-KDEA12);
买卖均力:=SMA(买卖力道,5,2);
DIF:=DIF12;
DEA:=DEA12;
微分DIF:=KDIF12;
微分DEA:=KDEA12;
{*3}M尖:=(IF(MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2),1,0));
{*4}M3金:=(CROSS(C,WMA(C,3)));
快乐个股资金线:=MA(C,1)/MA(REF(C,13),13)*300-150;
快乐资金生命线:=MA(FORCAST(快乐个股资金线,21),8);
快乐金:=CROSS(快乐个股资金线,快乐资金生命线);
资金线:=MA(C,1)/MA(REF(C,18),18)*100;
生命线:=MA(FORCAST(资金线,20),6);
资金金:=CROSS(资金线,生命线);{42.18--136214};
XG:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,60)
AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,60);
{*5}包4线:=(快乐金 AND XG);
{陈主图分析}
箱顶:=HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58);
箱底:=LLV(MA((LOW+HIGH+CLOSE+O)/4,6),88);
VAR2:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
VAR3:=(3*VAR2-2*SMA(VAR2,5,1))*0.3;
VAR4:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VAR5:=EMA(3*VAR4-2*SMA(VAR4,18,1),5);
VAR6:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VAR7:=3*SMA(VAR6,3,1)-2*SMA(SMA(VAR6,3,1),5,1);
VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
VARA:=EMA(VAR9,5);
资金流向:=(VAR9-VARA+箱底)*1;
VARG1:=1.86*EMA(CLOSE,5)-EMA(CLOSE,13);
趋势力度:=VARG1;
K2:=BACKSET(趋势力度>REF(趋势力度,1),2);
粉红:=IF(K2,趋势力度,趋势力度);
AS:=箱底;
MA3:=MA(C,3);
MA21:=MA(C,21);
K1:=BACKSET(MA21>REF(MA21,1),2);
强A:=IF(K1,MA21,MA21);
FL:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
FS:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
CG:=IF(MA(CLOSE,17)<FS,FS,MA(CLOSE,17));
年线:=EMA(C,250);
浮筹:=CG-(EMA(C,3)-CG);
散筹:=年线-(EMA(C,3)-年线);
{*6}二级:=(CROSS(趋势力度,浮筹));
{白上一定涨}
均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价)/5;
R1:=(2*H+3*均价)/5;
KX:=(R+R1)/2;
ZJ1:=AMOUNT/VOL/100;
ZJ3:=SUM(AMOUNT,35)/ZJ1/100;
ZJ4:=DMA(KX,VOL/ZJ3);
ZJ:=100*(KX-ZJ4)/ZJ4;
上轨:=(MA(ZJ,20)+STDP(ZJ,20));
下轨:=(MA(ZJ,20)-STDP(ZJ,20));
强轨:=(MA(ZJ,20)+1.7*STDP(ZJ,20));
弱轨:=(MA(ZJ,20)-1.7*STDP(ZJ,20));
标准线:=ZJ;
强弱线:=(上轨+下轨)/2;
CCI:=(R-MA(R,84))/(0.015*AVEDEV(R,84))/20;
做多:=(3*SMA(CCI,2,1)+2*SMA(SMA(CCI,2,1),2,1))/5;
白C:=IF(CCI<做多,CCI,DRAWNULL);
WR1:=(100*(HHV(R1,42)-KX)/(HHV(R1,42)-LLV(R,42)))/20*5-10;
做空:=(3*SMA(WR1,2,1)+2*SMA(SMA(WR1,2,1),2,1))/5;
白WR1:=IF(WR1>做空,WR1,DRAWNULL);
{*7}白↑强:=(CROSS(标准线,强轨) AND CROSS(今强,上轨));
N1:=6; N2:=12; N3:=24;
YLC:=周月RSI引用.LC#MONTH;
YY11:=周月RSI引用.YN11#MONTH;
YY12:=周月RSI引用.YN12#MONTH;
YY21:=周月RSI引用.YN21#MONTH;
YY22:=周月RSI引用.YN22#MONTH;
YY31:=周月RSI引用.YN31#MONTH;
YY32:=周月RSI引用.YN32#MONTH;
YRSI1:=((MAX(C-YLC,0)+YY11*(N1-1))/N1)/((ABS(C-YLC)+YY12*(N1-1))/N1)*100;
YRSI2:=((MAX(C-YLC,0)+YY21*(N2-1))/N2)/((ABS(C-YLC)+YY22*(N2-1))/N2)*100;
YRSI3:=((MAX(C-YLC,0)+YY31*(N3-1))/N3)/((ABS(C-YLC)+YY32*(N3-1))/N3)*100;
月RSI1:=YRSI1;
月RSI2:=YRSI2;
月RSI3:=YRSI3;
沧海行周J:="KDJ.J#WEEK";
沧海行周D:="KDJ.D#WEEK";
沧海行周MA:=50*"MACD.MACD#WEEK";
零点:=(CONST(LLV(沧海行周MA,90))+CONST(HHV(沧海行周MA,90)))/2;
DI:=月RSI1;
F分:=CONST(LLV(DI,90));
F百:=CONST(HHV(DI,90))-F分;
点:=CONST(LLV(沧海行周MA,90));
基:=CONST(HHV(沧海行周MA,90))-点;
F比:=(DI-F分)/F百;
XFX:=F比*基+点;
月RSI1叠加:=XFX;
{双轨}
AHC1:=CLOSE*VOL;
AHC11:=EMA((EXPMA(AHC1,1)/EXPMA(VOL,1)+EXPMA(AHC1,2)/EXPMA(VOL,2)+EXPMA(AHC1,4)/EXPMA(VOL,4)+EXPMA(AHC1,6)/EXPMA(VOL,6))/4,7);
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13);
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,13);
顶:=1.3*AHC2;
内上:=1.06*AHC2;
内下:=AHC2*0.94;
底:=AHC2*0.87;
~11:=1.03*AHC2;
~22:=0.97*AHC2;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
{*8}启爆:=(CROSS(C,内上) OR CROSS(C,内下) AND ZT);
上通道:=MA(L+(H-L)/2,25)*1.15;
下通道:=MA(L+(H-L)/2,25)*0.95;
中轨:=(上通道+下通道)/2;
股价:=C;
次上通道:=(MA(C,5)+MA(O,5))/2*1.06;
次下通道:=(MA(C,5)+MA(O,5))/2*0.98;
强弱线2:=(次上通道+次下通道)/2;
{*9}C↑次上:=(CROSS(C,次上通道));
现价线:=DYNAINFO(7);
N:=2;K:=12;P:=24;
BG:=BARSCOUNT(C)+2;
NB:=IF(BG<N,BG,N);
KB:=IF(BG<K,BG,K);
PB:=IF(BG<P,BG,P);
MN:=SUM(C,NB)/SUM(1,NB);
MN2:=SUM(C*C,NB)/SUM(1,NB);
MK:=SUM(C,KB)/SUM(1,KB);
MK2:=SUM(C*C,KB)/SUM(1,KB);
MP:=SUM(C,PB)/SUM(1,PB);
MP2:=SUM(C*C,PB)/SUM(1,PB);
MA_S:=POW(MN*MK*MP,1/3);
XZN:=NB/(NB-1);
XZK:=KB/(KB-1);
XZP:=PB/(PB-1);
SD1:=(MN2-MN*MN)*XZN;
SD2:=(MK2-MK*MK)*XZK;
SD3:=(MP2-MP*MP)*XZP;
SD:=SQRT((SD1+SD2+SD3)/3);
顶线:=MA_S+2*SD;
强线:=MA_S+SD;
中线:=MA_S;
弱线:=MA_S-SD;
底线:=MA_S-2*SD;
{人上}
X:=HHV(H,5)-REF(O,5);
Y:=C-LLV(L,5);
Z:=(HHV(H,5)-LLV(L,5))*2;
{*10}强弱50:=(IF((C-L)/(H-L)*100>=100,1,0));
{*11}摆荡70:=(IF((X+Y)/Z*100>=100,1,0));
NN:=2;
NN2:=2;
DD:=8;
角度2:=-30;
买:=REF(CLOSE, 1)*(1-NN/100);
卖:=REF(CLOSE, 1)*(1+NN2/100);
天:=100;
地:=0;
VVAR2:=(CLOSE-LLV(LOW, 4))/(HHV(HIGH, 4)-LLV(LOW, 4))*100;
VVAR3:=SMA(VVAR2, 3, 1);
VVAR4:=CLOSE<=1*REF(CLOSE, 1);
VVAR5:=SMA(VVAR3, 3, 1);
人:=3*VVAR3-2*VVAR5;
VVAR6:=人>=1*REF(人, 1);
VVAR7:=人<=1*REF(人, 1);
和:=MA(人, 3);
VVAR8:=和<=1*REF(和, 1);
VVAR9:=(CLOSE-LLV(LOW, 45))/(HHV(HIGH, 45)-LLV(LOW, 45))*100;
VVAR10:=(CLOSE-REF(OPEN, 29))/REF(OPEN, 29)*100;
VAR11:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
看长K:=SMA(VAR9, 3, 1);
做短D:=SMA(看长K, 3, 1);
VVAR12:=MA(人, 5);
VVAR13:=MA(人, 10);
NNN:=21;
CYF:=100-100/(1+EMA(HSL,NNN))*5;
MACYF:=MA(CYF,8);
量_价:=1; CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;
TJB:=ZZ<=MIN(C,O) AND CTKG=1;
ZF:=IF(TJA,1,IF(TJB,-1,0));
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);
TJ2:=H=L AND C<REF(C,1);
TJ3:=H=L AND C=REF(C,1);
量_价:=IF(W=1,VOL,AMOUNT); EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
买卖差:=JGL_DX*量_价;
DX%:=JGL_DX*100;
主动买:=量_价*(1+JGL_DX)/2;
主动卖:=量_价*(1-JGL_DX)/2;
JDZ:=ABS(买卖差);
MMC:=IF(BARSCOUNT(C),买卖差,0);
短:=SMA(SUM(MMC,12),9,2)/2.5;
中:=SMA(SUM(MMC,34),9,2)/4;
长:=SMA(SUM(MMC,55),9,2)/6.5;
强:=IF(短>REF(短,1),短,MA(短,256000));
{*12}多头1:=(C=HHV(H,60));
{*13}多头2:=(C=HHV(H,20));
成交:=VOL,POINTDOT,COLORYELLOW;
主买:=IF(CLOSE>OPEN,VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*(HIGH-LOW),IF(CLOSE<OPEN,VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
{*14}青云:=IF(FILTER(MR,10),1,0);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
{*15}暴:=IF((FILTER((VAR4AA>90),45))>0,1,0);
T:=IF((BARSCOUNT(C) > 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) - 1),1);
WJ:=((-((100)*(HHV(H,(IF((T > 0.35),6,65))) - C))/(HHV(HIGH,(IF((T > 0.35),6,65))) - LLV(L,(IF((T > 0.35),6,65))))));
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
BB:=MA(SUM(J1-J2,22),3);
累加:=21*BB+20*REF(BB,1)+19*REF(BB,2)+18*REF(BB,3)+17*REF(BB,4)
+16*REF(BB,5)+15*REF(BB,6)+14*REF(BB,7)+13*REF(BB,8)+12*REF
(BB,9)+11*REF(BB,10)+10*REF(BB,11)+9*REF(BB,12)+8*REF(BB,13)
+7*REF(BB,14)+6*REF(BB,15)+5*REF(BB,16)+4*REF(BB,17)+3*REF
(BB,18)+2*REF(BB,19)+REF(BB,20);
WMA1:=累加/(21+1)/21*2;
CCJ:=WMA1;
VAR4J:=SMA(RV,3,1);
VAR5J:=SMA(VAR4J,3,1);
KK:=EMA(SMA(RG,3,1),2);
DDJ:=SMA(KK,3,1);
{*16}涨百:=CROSS(WJ,-2) AND CROSS(VAR4J,VAR5J) AND CROSS(KK,DDJ);
{*17}三光:=C=H AND C#MIN60=H#MIN60 AND C#WEEK=H#WEEK AND C#MONTH=H#MONTH AND C#SEASON=H#SEASON;
{*18}准70:=IF((LLV(C,30)>=LLV(C,2) AND C/REF(C,1)>(1+8.8/100))*30>0,1,0);
走强线:=EMA(COST(99),181);
巨量平台:=REF(H,BARSLAST(V=HHV(VOL,120)));
主升:=CROSS(C,巨量平台);
{*19}超升:=IF(主升 AND REF(C,1)*1.1-C<0.01 AND H=C,1,0);
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,5));
{*20}涨停:=FILTER(LS,28);
LS2:=C/REF(C,1)>1.03 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
YZB:=C/REF(C,1)>1.0991 AND O=H AND C=H;
{*21}上车:= FILTER(LS2,28) AND NOT(YZB),COLORRED,LINETHICK3;
绝佳:=IF(OPEN > REF(H, 1) AND OPEN / REF(CLOSE,1) >=1.03 AND C > OPEN
AND REF(H, 1) < LOW AND H / C <= 1.01 AND
(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)<0.3,8,0),COLORWHITE ;
{*22}佳:=IF(绝佳>0,1,0),COLORWHITE ;
ZT2:=REF(C,1)*1.1-C<0.01 AND H=C;
高位:=COST(99.9);
主力底仓:=COST(1);
上突破:=高位>REF(高位,1) AND REF(高位,1)<=REF(高位,2);
下突破:=高位<=REF(高位,1) AND REF(高位,1)>REF(高位,2);
高点:=DRAWLINE(上突破,REF(高位,1),REF(上突破,1),REF(REF(高位,1),1),1);
前高:=DRAWLINE(下突破,高位,REF(下突破,1),REF(高位,1),1);
{*23}龙头:=CROSS(C,高点) OR CROSS(C,前高) AND ZT2;
YY1:=C>MA(C,5) AND O<MA(C,5);
YY3:=C>MA(C,10) AND O<MA(C,10);
YY5:=C>MA(C,20) AND O<MA(C,20);
YY7:=C>MA(C,57) AND O<MA(C,57);
YY8:=L>MA(C,45) AND REF(C,1)<MA(C,67);
芙蓉出水:=YY1 AND YY5 AND YY3 AND YY7 ;{50.47---1120};
XGG:=MACD.MACD>0 AND COUNT(MACD.MACD>0,2)>=1 AND COUNT(MACD.MACD<0,2)=1 ;
{*24}芙蓉:=芙蓉出水 AND XGG;
{*25}一穿4:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,60)
AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,60);
连涨天数:=BARSLASTCOUNT(C>REF(C,1));
连涨幅:=IF(C>REF(C,1),(C-REF(C,连涨天数))/REF(C,连涨天数)*100,0);
换手:=V/CAPITAL*100;
大换手天:=BARSLASTCOUNT(换手>4);
换手减少:=换手<REF(换手,1);
{*26}西电:=连涨天数>3 AND 连涨幅>0.038 AND 大换手天>3 ;{56.35}
{********************}
W10:=M3金+二级+启爆+C↑次上+强弱50+多头2+暴+超升+涨停+上车;
G6:=M3金+启爆+C↑次上+强弱50+摆荡70+三光;
T9:=启爆+C↑次上+强弱50 +多头1+多头2+暴+涨停+上车+佳 ;
T11:=二级+启爆+C↑次上+强弱50+摆荡70+多头1+多头2+暴+涨停+上车+龙头;
H8:=M3金+C↑次上+强弱50+青云+涨百+准70+涨停+上车;
L7:=二级+启爆+C↑次上+强弱50+多头2+暴+涨停;
Z17:=二级+启爆+C↑次上+强弱50 +多头2+暴+涨停+上车;
WX4:=M尖+M3金+强弱50+三光;
H10:=二级+启爆+C↑次上+强弱50+摆荡70+多头2+三光+涨停+上车+西电 ;
P8:=M尖+包4线+C↑次上+强弱50+涨停+上车+芙蓉+一穿4;
J10:=差标上+M尖+启爆+C↑次上+强弱50 +多头2 +暴+涨停+上车+一穿4 ;
C11:=M尖+二级+白↑强+启爆+C↑次上+强弱50 +多头2 +三光+涨停+上车+佳;
J8:=差标上+M尖+启爆+C↑次上+强弱50 +多头2 +暴+涨停+上车;
C5:=差标上+二级+C↑次上+强弱50+摆荡70;
F8:=差标上+M尖+M3金+包4线+强弱50+青云+涨百+一穿4;
Y9:=M尖+M3金+包4线+启爆+强弱50+青云+涨停+上车+一穿4;
总1:=((C穿黄水平线*49.92+差标上*41.65+M尖*42.06+
M3金*41.95+包4线*43.53+二级*37.195+白↑强*42.04+启爆*41.65+C↑次上*37.87+强弱50*42.23+摆荡70*41.56));
总2:=多头1*42.45+多头2*42.29
+青云*39.86+暴*40.7+涨百*42.63+三光*63.17+准70*45.59+超升*42.43+涨停*42.41+上车*41.42+佳*41.35+龙头*44.4+芙蓉*43.61+一穿4*45.08;
总3:=西电*56.35;
总分列:=总1+总2+总3;
总1无权重:=((C穿黄水平线+差标上+M尖+
M3金+包4线+二级+白↑强+启爆+C↑次上+强弱50+摆荡70));
总2无权重:=多头1+多头2
+青云+暴+涨百+三光+准70+超升+涨停+上车+佳+龙头+芙蓉+一穿4;
总3无权重:=西电;
总分列无权重:=总1无权重+总2无权重+总3无权重;
大成26:IF(DYNAINFO(7)=0 OR DYNAINFO(9)=0,0,总分列);
大成无权重26:IF(DYNAINFO(7)=0 OR DYNAINFO(9)=0,0,总分列无权重);
样金:=W10+G6+T9+T11+H8+L7+Z17+WX4+H10+P8+C11+J8+C5+F8+Y9+W;
总样金:IF(DYNAINFO(7)=0 OR DYNAINFO(9)=0,0,样金);
文10:W10;
贵6:G6;
泰9:T9;
天11:T11;
华森8:H8;
蓝7:L7;
中17:Z17;
万4:WX4;
宏10:H10;
盘8:P8;
诚11:C11;
九8:J8;
创5:C5;
锋8:F8;
永9:Y9;


牛股排序 源码 通达信 贴图

好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
相关说明
  1. 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  2. 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  3. 判断公式指标好坏,请用户参考用户评论或者软件好评度
  4. alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  5. fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  6. exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  7. tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  8. tne格式公式,仅可以用鸿运国际官网编辑器5.0版导入,高版本兼容低版本;
  9. hxf格式股票公式,仅可以用鸿运国际官网股票软件引入使用。
  10. 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  11. 如果您发现下载链接错误,请点击报告错误谢谢!
鸿运国际官网